1. You can now help support WorldwideDX when you shop on Amazon at no additional cost to you! Simply follow this Shop on Amazon link first and a portion of any purchase is sent to WorldwideDX to help with site costs.

Cobra 29 with low/no Rx, Tx OK.

Discussion in 'General CB Services Discussion' started by n7jld, May 2, 2013.

  1. n7jld

    n7jld
    Expand Collapse
    Member

    Joined:
    May 2, 2013
    Messages:
    1
    Likes Received:
    0
    I have a Cobra 29 LTD NW that had garbled receive audio after warming up for about 5-20 minutes (was clear and strong when first powered up). I put it on the shelf for about two years. Then I ran across a receiver mod on eBay. New T27(I think) and 3 new diodes. I installed the components as instructed hoping to alleviate the garbled audio. Surprise, no audio at all! So, I hooked up a speaker to the P.A. jack and got audio (yes the meter is working also) and the mic (Astatic) worked for P.A. With the radio in CB mode (as opposed to P.A. mode). the meter still shows the same receive level (about S4 +/-) as in P.A. mode. The radio transmits just fine, showing nearly full swing on the meter and good Tx audio quality heard by another radio. So to sum it up, Tx OK, no Rx.
    any thoughts? worth fixing?


     
  2. MudDuck442

    MudDuck442
    Expand Collapse
    Active Member

    Joined:
    Mar 24, 2013
    Messages:
    130
    Likes Received:
    32
    Yes and simple. If you are getting RX audio in the PA mode then it is somewhere in the switching circuit that routes the rx audio basically from one jack to another (pcb gnd actually) also make sure your mic is giving a gnd path as well in rx as well. If I am reading your post correctly and you are in fact getting RX audio in the PA mode, that is.
     

Share This Page