1. You can now help support WorldwideDX when you shop on Amazon at no additional cost to you! Simply follow this Shop on Amazon link first and a portion of any purchase is sent to WorldwideDX to help with site costs.

Galaxy dx2547 (959) No squelch

Discussion in 'General CB Services Discussion' started by CbRadiosPRONTO, Apr 20, 2017.

  1. CbRadiosPRONTO

    CbRadiosPRONTO
    Expand Collapse
    Performance Ready Radios

    Joined:
    Mar 21, 2014
    Messages:
    323
    Likes Received:
    50
    cannot engage squelch (constant static). Squelch pot is adjusting correctly 0-50k. The problem is on both AM and SSB, however I check Vr3/d15 and vr4/d35 anyway, and they're good.

    Should I be looking at IC1 or possibly a transistor? I don't have a voltage chart.



    Suggestions?
     

  2. Robb

    Robb
    Expand Collapse
    Yup

    Joined:
    Dec 18, 2008
    Messages:
    10,343
    Likes Received:
    2,106
    Here ya go
     

    Attached Files:

    LeapFrog likes this.
  3. CbRadiosPRONTO

    CbRadiosPRONTO
    Expand Collapse
    Performance Ready Radios

    Joined:
    Mar 21, 2014
    Messages:
    323
    Likes Received:
    50
    IC1 checks out, including pin 8, which adjusts in voltage as squelch pot is increased.

    Suggestions?
     
  4. Robb

    Robb
    Expand Collapse
    Yup

    Joined:
    Dec 18, 2008
    Messages:
    10,343
    Likes Received:
    2,106
    Maybe the squelch isn't the problem; check feed signal to the squelch?
     
  5. CbRadiosPRONTO

    CbRadiosPRONTO
    Expand Collapse
    Performance Ready Radios

    Joined:
    Mar 21, 2014
    Messages:
    323
    Likes Received:
    50
    Umm
     
  6. CbRadiosPRONTO

    CbRadiosPRONTO
    Expand Collapse
    Performance Ready Radios

    Joined:
    Mar 21, 2014
    Messages:
    323
    Likes Received:
    50
    I handle general radio work whereas my vacationing tech normally handles the tech stuff.
     
  7. Robb

    Robb
    Expand Collapse
    Yup

    Joined:
    Dec 18, 2008
    Messages:
    10,343
    Likes Received:
    2,106
    Not a tech either; but it seems like a logical guess.
     
  8. CbRadiosPRONTO

    CbRadiosPRONTO
    Expand Collapse
    Performance Ready Radios

    Joined:
    Mar 21, 2014
    Messages:
    323
    Likes Received:
    50
    Thanks, Robb. I traced it back to Q44. The trace was pulled away from the board, slightly. Re flowing the solder did not fix it though. Q44 was actually bad. It must have gone bad from having the bad connection.

    She's back in business.

    PS: This is a fresh out of the IMG_0180.JPG box radio. Arg. Happens too often.
     
    Robb likes this.

Share This Page